Small cohort of customers are unable to access JPD

Incident Report for Jira Product Discovery

Resolved

The small cohort of Jira Product Discovery customers no longer face any issues in accessing their JPD Sites. We are implementing measures to prevent similar issues from occurring in the future.
Posted Jun 23, 2025 - 13:25 UTC

Investigating

We are investigating reports of Jira Product Discovery being unavailable for a small cohort of customers.
Posted Jun 23, 2025 - 12:42 UTC
This incident affected: Open projects, Create and delete fields, and Add/view data points ("Capture").