Data viewing issues on Jira Product Discovery

Incident Report for Jira Product Discovery

Resolved

On June 12th 2026, between 07:30 UTC to 13:48 UTC, some users experienced viewing disruptions with our product discovery service.

The issue has now been resolved and the service is operating normally for all the customers.
Posted Jun 12, 2026 - 14:29 UTC

Monitoring

We are investigating reports of incomplete or missing field data in Jira Product Discovery views, including list, timeline, and single idea views. A limited number of customers are affected. Your data is safe, this is a display issue only.

We have identified the root cause and a fix is being deployed. We will provide an update once recovery is confirmed.
Posted Jun 12, 2026 - 13:50 UTC
This incident affected: Open projects, Create and delete fields, and Add/view data points ("Capture").